Menu kategorii
  • Excel - jak obliczyć średnią i średnią ważoną

    Excel - jak obliczyć średnią i średnią ważoną

     Łukasz Klimkiewicz
    Łukasz Klimkiewicz
    12:00
    11.07.2019
    522 wyświetlenia

    Liczenie średniej wartości liczb i średniej ważonej to czynności wykonywane najczęściej przez nauczycieli w celu wystawienia ocen końcowych swoim uczniom. Można te działania wykonać za pomocą kalkulatora lub ręcznie na kartce papieru, ale łatwiej i szybciej będzie skorzystać z odpowiednich funkcji w programie Excel. W tym krótkim poradniku pokażemy, jak obliczyć średnią oraz średnią ważoną.

    Poniższy zrzut ekranu prezentuje zestaw danych, z którym będziemy pracować. Na grafice widzimy oceny uczniów za konkretne zadania oraz przypisaną do tych zadań wagę oceny.

    Arkusz Excel

    Średnia arytmetyczna

    Średnią arytmetyczną możemy policzyć za pomocą funkcji ŚREDNIA(), do której dołączamy zakres komórek, który będzie uwzględniony w działaniu.

    W przypadku naszego zestawu danych zaznaczamy komórkę K4, rozpoczynamy konstruowanie formuły =ŚREDNIA(D4:J4) i zatwierdzamy ją klawiszem Enter. Wynik działania formuły przeciągamy do pozostałych komórek w kolumnie K.

    Arkusz Excel

    Średnia ważona

    Średnia ważona jest formułą obliczającą sumę wartości ze zbioru, podzieloną przez liczbę wartości w danym zbiorze z uwzględnieniem ważności (wag) danych wartości. Liczenie średniej ważonej w Excelu jest trochę bardziej skomplikowane, ale też nie należy do czynności dla zaawansowanych użytkowników. W tym wypadku będziemy korzystać z funkcji SUMA.ILOCZYNÓW() oraz SUMA.

    W przypadku naszego zestawu danych zaznaczamy komórkę L4 i rozpoczynamy konstruowanie formuły - =SUMA.ILOCZYNÓW(D4:J4;$D$3:$J$3)/SUMA($D$3:$J$3). Zatwierdzamy klawiszem Enter. Co robią te funkcje? SUMA.ILOCZYNÓW liczy nam iloczyn wartości zapisanych w zakresie od komórki D4 do komórki J4 wraz z zakresem komórek D3 do J3. Wynik tego działania dzielony jest przez sumę wartości zapisanych w zakresie D3 do J3. Zwróćmy uwagę, że w przypadku zakresu D3 do J3 wprowadziliśmy symbol $. W tym wypadku należy go zastosować, ponieważ blokuje on kolumnę oraz wiersz, z którego pobierane są dane. To ważne w przypadku późniejszego przeciągania wyników formuły do kolejnych wierszy.

    Arkusz Excel


    Spodobał Ci się ten artykuł? Podziel się z innymi!

    Źródło:

    Polecamy również w kategorii Porady Excel 2019