Menu kategorii
  • Excel - przenosznie lub kopiowanie formuły

    Excel - przenosznie lub kopiowanie formuły

     Wojciech Błachno
    Wojciech Błachno
    12:00
    02.09.2019
    172 wyświetlenia

    Formuły to jedno z podstawowych narzędzi Excela. Czasem możemy mieć potrzebę wykorzystania jednej z formuł w innym arkuszu. Taką formułę możemy albo przenieść, albo przekopiować. W zależności od metody formuła będzie zwracała inne wyniki.

    Przenoszenie formuły

    Aby przenieść formułę, możemy ją po prostu wyciąć z arkusza źródłowego i wkleić do docelowego. Możemy to zrobić za pomocą skrótów Ctrl+X i Ctrl - V albo wybierając pozycję Wytnij z menu kontekstowego wywołanego poprzez naciśnięcie prawego klawisza myszy.

    Przy wykorzystaniu tej metody, odwołania do komórek pozostają bez zmian - komórka zwraca te same dane jak pierwotnie. Co więcej, jeśli formuła SUMA zliczała wartość komórek A1 i B1 w Arkuszu 1, to po przeniesieniu do Arkusza 2 formuła nadal będzie pobierać dane z arkusza pierwszego:

    =SUMA(Arkusz1!A1:B1)

    Jeśli nie chcemy zachowywać pierwotnego formatowania, to powinniśmy wkleić formułę korzystając z opcje Wklej specjalnie - Formuły, którą znajdziemy w menu kontekstowym.

    Excel kopiowanie i przenoszenie formuły

    Kopiowanie formuły

    Jeśli natomiast chcemy skopiować samą formułę, bez pierwotnych odwołań, wystarczy ją skopiować za pomocą dobrze znanego skrótów Ctrl-C i Ctrl-V, lub wybierając opcję Kopiuj z menu kontekstowego. Po wklejeniu w kolejnym arkuszu formuła pobierze dane z odpowiednich komórek i zwróci wynik.

    Jeśli po skopiowaniu formułą nie zwraca odpowiedniego wyniku, warto sprawdzić typ odwołania. W polu formuły za pomocą znaku $ możemy zmienić jego typ z odwołania bezwzględnego na odwołanie względne.

    Jeśli jednak nie chcemy kopiować w ten sposób całej formuły, tylko sam jej wynik, wystarczy wybrać opcję Wklej - Wklej specjalnie - Wartości.


    Spodobał Ci się ten artykuł? Podziel się z innymi!

    Źródło:

    Polecamy również w kategorii Porady Excel 2019